# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d+)\.(\d+\.\d+)$/$1_$2/mg;t' <<< "2.2.3.140113"