use strict;
my $str = '2.2.3.140113';
my $regex = qr/^(\d+)\.(\d+\.\d+)$/mp;
my $subst = '$1_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";