import Foundation
let pattern = #"^(\d+)\.(\d+\.\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2.2.3.140113"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1_$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)