package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+)\.(\d+\.\d+)$`)
var str = `2.2.3.140113`
var substitution = "$1_$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}