$re = '/^(\d+)\.(\d+\.\d+)$/m';
$str = '2.2.3.140113';
$subst = "$1_$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;