using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<(?!a\b)(\w+)\b(?>(?:(?!</?\2\b).)+(?1)?)*</\2>)(*SKIP)(*F)|<a\b.*?</a>\s*";
string input = @"Hi Hello <a href=""#"">World</a>. This is
<div class=""some"">testing <a href=""#"">content</a>. some more content</div>
<a href=""#"">World</a>
<div class=""some"">
<div class=""some"">testing <a href=""#"">content</a>. some more content</div>
<span>abc</span>
<a href=""#"">World</a>
</div>
<a href=""#"">World</a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}