import re
regex = re.compile(r"(<(?!a\b)(\w+)\b(?>(?:(?!</?\2\b).)+(?1)?)*</\2>)(*SKIP)(*F)|<a\b.*?</a>\s*", flags=re.IGNORECASE | re.DOTALL)
test_str = ("Hi Hello <a href=\"#\">World</a>. This is\n"
"<div class=\"some\">testing <a href=\"#\">content</a>. some more content</div>\n"
"<a href=\"#\">World</a>\n"
"<div class=\"some\">\n"
" <div class=\"some\">testing <a href=\"#\">content</a>. some more content</div>\n"
" <span>abc</span>\n"
" <a href=\"#\">World</a>\n"
"</div>\n"
"<a href=\"#\">World</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")