import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<(?!a\\b)(\\w+)\\b(?>(?:(?!</?\\2\\b).)+(?1)?)*</\\2>)(*SKIP)(*F)|<a\\b.*?</a>\\s*";
final String string = "Hi Hello <a href=\"#\">World</a>. This is\n"
+ "<div class=\"some\">testing <a href=\"#\">content</a>. some more content</div>\n"
+ "<a href=\"#\">World</a>\n"
+ "<div class=\"some\">\n"
+ " <div class=\"some\">testing <a href=\"#\">content</a>. some more content</div>\n"
+ " <span>abc</span>\n"
+ " <a href=\"#\">World</a>\n"
+ "</div>\n"
+ "<a href=\"#\">World</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}