const regex = new RegExp('(<(?!a\\b)(\\w+)\\b(?>(?:(?!</?\\2\\b).)+(?1)?)*</\\2>)(*SKIP)(*F)|<a\\b.*?</a>\\s*', 'gis')
const str = `Hi Hello <a href="#">World</a>. This is
<div class="some">testing <a href="#">content</a>. some more content</div>
<a href="#">World</a>
<div class="some">
<div class="some">testing <a href="#">content</a>. some more content</div>
<span>abc</span>
<a href="#">World</a>
</div>
<a href="#">World</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}