$re = '~(<(?!a\b)(\w+)\b(?>(?:(?!</?\2\b).)+(?1)?)*</\2>)(*SKIP)(*F)|<a\b.*?</a>\s*~is';
$str = 'Hi Hello <a href="#">World</a>. This is
<div class="some">testing <a href="#">content</a>. some more content</div>
<a href="#">World</a>
<div class="some">
<div class="some">testing <a href="#">content</a>. some more content</div>
<span>abc</span>
<a href="#">World</a>
</div>
<a href="#">World</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);