#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?:https?:\/\/)?(?:www\.)?facebook\.com"
Local $sString = "http://www.facebook.com/sdfsd" & @CRLF & _
"https://www.facebook.com/sdfsd" & @CRLF & _
"www.facebook.com/sdfsd" & @CRLF & _
"http://www.facebook.com/sdfsd" & @CRLF & _
"facebook.com/sdsdfsd" & @CRLF & _
"http://facebook.com/sdfsd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")