using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?(?:www\.)?facebook\.com";
string input = @"http://www.facebook.com/sdfsd
https://www.facebook.com/sdfsd
www.facebook.com/sdfsd
http://www.facebook.com/sdfsd
facebook.com/sdsdfsd
http://facebook.com/sdfsd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}