re = /^(?:https?:\/\/)?(?:www\.)?facebook\.com/im
str = 'http://www.facebook.com/sdfsd
https://www.facebook.com/sdfsd
www.facebook.com/sdfsd
http://www.facebook.com/sdfsd
facebook.com/sdsdfsd
http://facebook.com/sdfsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end