const regex = /^(?:https?:\/\/)?(?:www\.)?facebook\.com/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(?:www\\.)?facebook\\.com', 'igm')
const str = `http://www.facebook.com/sdfsd
https://www.facebook.com/sdfsd
www.facebook.com/sdfsd
http://www.facebook.com/sdfsd
facebook.com/sdsdfsd
http://facebook.com/sdfsd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}