$re = '/^(?:https?:\/\/)?(?:www\.)?facebook\.com/im';
$str = 'http://www.facebook.com/sdfsd
https://www.facebook.com/sdfsd
www.facebook.com/sdfsd
http://www.facebook.com/sdfsd
facebook.com/sdsdfsd
http://facebook.com/sdfsd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);