using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B@(?!.*(-){2,}.*)[a-z0-9](?:[a-z0-9-]{0,37}[a-z0-9])?\b";
string input = @"@username
@user in a @user2 pagagraph of @user: text @usern-ame! @inalid-
@d
@12345678912345678912345678911112345678904
@invalid--username
and @valid-username-: l
@-invalid
@1
@a
@invalid-
hdj @hfd.com
some @valid-dd username
email@test.com
@validu-sername
@johndoe.
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}