import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B@(?!.*(-){2,}.*)[a-z0-9](?:[a-z0-9-]{0,37}[a-z0-9])?\\b";
final String string = "@username\n\n"
+ "@user in a @user2 pagagraph of @user: text @usern-ame! @inalid- \n\n"
+ "@d\n\n"
+ "@12345678912345678912345678911112345678904 \n\n"
+ "@invalid--username\n\n"
+ "and @valid-username-: l\n\n"
+ "@-invalid\n"
+ "@1\n"
+ "@a\n\n"
+ "@invalid-\n\n"
+ "hdj @hfd.com\n\n"
+ "some @valid-dd username\n\n"
+ "email@test.com \n\n"
+ "@validu-sername\n\n"
+ "@johndoe.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}