import re
regex = re.compile(r"\B@(?!.*(-){2,}.*)[a-z0-9](?:[a-z0-9-]{0,37}[a-z0-9])?\b", flags=re.IGNORECASE)
test_str = ("@username\n\n"
"@user in a @user2 pagagraph of @user: text @usern-ame! @inalid- \n\n"
"@d\n\n"
"@12345678912345678912345678911112345678904 \n\n"
"@invalid--username\n\n"
"and @valid-username-: l\n\n"
"@-invalid\n"
"@1\n"
"@a\n\n"
"@invalid-\n\n"
"hdj @hfd.com\n\n"
"some @valid-dd username\n\n"
"email@test.com \n\n"
"@validu-sername\n\n"
"@johndoe.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")