use strict;
my $str = '@username
@user in a @user2 pagagraph of @user: text @usern-ame! @inalid-
@d
@12345678912345678912345678911112345678904
@invalid--username
and @valid-username-: l
@-invalid
@1
@a
@invalid-
hdj @hfd.com
some @valid-dd username
email@test.com
@validu-sername
@johndoe.
';
my $regex = qr/\B@(?!.*(-){2,}.*)[a-z0-9](?:[a-z0-9-]{0,37}[a-z0-9])?\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}