re = /\B@(?!.*(-){2,}.*)[a-z0-9](?:[a-z0-9-]{0,37}[a-z0-9])?\b/i
str = '@username
@user in a @user2 pagagraph of @user: text @usern-ame! @inalid-
@d
@12345678912345678912345678911112345678904
@invalid--username
and @valid-username-: l
@-invalid
@1
@a
@invalid-
hdj @hfd.com
some @valid-dd username
email@test.com
@validu-sername
@johndoe.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end