#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\s*(?:\+?\d{1,3})?[-. (]*\d{3}[-. )]*\d{3}[-. ]*\d{4}(?: *x(\d+))?\s*)"
Local $sString = "Contact us via jobsearcher@gmail.com or you can use one of this phones: " & @CRLF & _
"" & @CRLF & _
"754-3010 Local" & @CRLF & _
"(541) 754-3010 Domestic" & @CRLF & _
"+1-541-754-3010 International" & @CRLF & _
"1-541-754-3010 Dialed in the US" & @CRLF & _
"001-541-754-3010 Dialed from Germany " & @CRLF & _
"191 541 754 3010 Dialed from Franc" & @CRLF & _
"636-48018 Local" & @CRLF & _
"(089) / 636-48018 Domestic" & @CRLF & _
"+49-89-636-48018 International" & @CRLF & _
"19-49-89-636-48018 Dialed from France" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")