import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\s*(?:\\+?\\d{1,3})?[-. (]*\\d{3}[-. )]*\\d{3}[-. ]*\\d{4}(?: *x(\\d+))?\\s*)";
final String string = "Contact us via jobsearcher@gmail.com or you can use one of this phones: \n\n"
+ "754-3010 Local\n"
+ "(541) 754-3010 Domestic\n"
+ "+1-541-754-3010 International\n"
+ "1-541-754-3010 Dialed in the US\n"
+ "001-541-754-3010 Dialed from Germany \n"
+ "191 541 754 3010 Dialed from Franc\n"
+ "636-48018 Local\n"
+ "(089) / 636-48018 Domestic\n"
+ "+49-89-636-48018 International\n"
+ "19-49-89-636-48018 Dialed from France\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}