const regex = /(^\s*(?:\+?\d{1,3})?[-. (]*\d{3}[-. )]*\d{3}[-. ]*\d{4}(?: *x(\d+))?\s*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\s*(?:\\+?\\d{1,3})?[-. (]*\\d{3}[-. )]*\\d{3}[-. ]*\\d{4}(?: *x(\\d+))?\\s*)', 'gm')
const str = `Contact us via jobsearcher@gmail.com or you can use one of this phones:
754-3010 Local
(541) 754-3010 Domestic
+1-541-754-3010 International
1-541-754-3010 Dialed in the US
001-541-754-3010 Dialed from Germany
191 541 754 3010 Dialed from Franc
636-48018 Local
(089) / 636-48018 Domestic
+49-89-636-48018 International
19-49-89-636-48018 Dialed from France
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}