# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\s*(?:\+?\d{1,3})?[-. (]*\d{3}[-. )]*\d{3}[-. ]*\d{4}(?: *x(\d+))?\s*)"
test_str = ("Contact us via jobsearcher@gmail.com or you can use one of this phones: \n\n"
"754-3010 Local\n"
"(541) 754-3010 Domestic\n"
"+1-541-754-3010 International\n"
"1-541-754-3010 Dialed in the US\n"
"001-541-754-3010 Dialed from Germany \n"
"191 541 754 3010 Dialed from Franc\n"
"636-48018 Local\n"
"(089) / 636-48018 Domestic\n"
"+49-89-636-48018 International\n"
"19-49-89-636-48018 Dialed from France\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.