#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)^([a-z\d"._-]{3,128})" & @CRLF & _
"(@)" & @CRLF & _
"([^-]" & @CRLF & _
"[a-z\d_-]*?" & @CRLF & _
"[^-]" & @CRLF & _
"\." & @CRLF & _
"[^-]" & @CRLF & _
"[a-z\d_-]*?" & @CRLF & _
"[^-])$"
Local $sString = "azazaza@f4.f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")