package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([a-z\d"._-]{3,128})
(@)
([^-]
[a-z\d_-]*?
[^-]
\.
[^-]
[a-z\d_-]*?
[^-])$`)
var str = `azazaza@f4.f`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}