using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(I|me)\b";
string substitution = @"You";
string input = @"I like candy";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}