$re = '/\b(I|me)\b/';
$str = 'I like candy';
$subst = "You";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;