#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?sm)^\S+[^:\r\n]*?(?=\s*:(?:(?!^\S).)*?Groundhog Day)"
Local $sString = "Person1 : movie1" & @CRLF & _
" (space and tab) : movie 2" & @CRLF & _
" (space and tab) : movie 3" & @CRLF & _
"Bill Murray :" & @CRLF & _
" (space and tab) : movie 4" & @CRLF & _
" (space and tab) : Groundhog Day"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")