import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?sm)^\\S+[^:\\r\\n]*?(?=\\s*:(?:(?!^\\S).)*?Groundhog Day)";
final String string = "Person1 : movie1\n"
+ " (space and tab) : movie 2\n"
+ " (space and tab) : movie 3\n"
+ "Bill Murray :\n"
+ " (space and tab) : movie 4\n"
+ " (space and tab) : Groundhog Day";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}