$re = '/(?sm)^\S+[^:\r\n]*?(?=\s*:(?:(?!^\S).)*?Groundhog Day)/m';
$str = 'Person1 : movie1
(space and tab) : movie 2
(space and tab) : movie 3
Bill Murray :
(space and tab) : movie 4
(space and tab) : Groundhog Day';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);