const regex = /(?sm)^\S+[^:\r\n]*?(?=\s*:(?:(?!^\S).)*?Groundhog Day)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sm)^\\S+[^:\\r\\n]*?(?=\\s*:(?:(?!^\\S).)*?Groundhog Day)', 'gm')
const str = `Person1 : movie1
(space and tab) : movie 2
(space and tab) : movie 3
Bill Murray :
(space and tab) : movie 4
(space and tab) : Groundhog Day`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}