re = /(?sm)^\S+[^:\r\n]*?(?=\s*:(?:(?!^\S).)*?Groundhog Day)/m
str = 'Person1 : movie1
(space and tab) : movie 2
(space and tab) : movie 3
Bill Murray :
(space and tab) : movie 4
(space and tab) : Groundhog Day'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end