import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:<p|\\G(?!^))(?:(?!<\\/p|<\\s*\\/?\\s*br).)*)<\\s*\\/?\\s*br\\s*\\/?\\s*>";
final String string = "These 2 lines should not be<br/>\n"
+ "touched. Example only.<br/><br/>\n\n"
+ "<pre class=\"code\">mysql>\n"
+ "<strong> SELECT state, COUNT(*) FROM president GROUP BY state;</strong><br/>\n"
+ "+-------+----------+<br/>\n"
+ "| state | COUNT(*) |<br/>\n"
+ "+-------+----------+<br/>\n"
+ "| OH | 7 |<br/>\n"
+ "| PA | 1 |<br/>\n"
+ "| SC | 1 |<br/>\n"
+ "| TX | 2 |<br/>\n"
+ "| VA | 8 |<br/>\n"
+ "| VT | 2 |\n"
+ "+-------+----------+\n"
+ "sdfsdf<br>\n"
+ "< /pre>\n"
+ "sdfsdf<br>\n"
+ "</pre>\n"
+ "kshdkjfkjshdf<br>\n"
+ "<p><br></p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}