import re
regex = re.compile(r"((?:<p|\G(?!^))(?:(?!<\/p|<\s*\/?\s*br).)*)<\s*\/?\s*br\s*\/?\s*>", flags=re.DOTALL)
test_str = ("These 2 lines should not be<br/>\n"
"touched. Example only.<br/><br/>\n\n"
"<pre class=\"code\">mysql>\n"
"<strong> SELECT state, COUNT(*) FROM president GROUP BY state;</strong><br/>\n"
"+-------+----------+<br/>\n"
"| state | COUNT(*) |<br/>\n"
"+-------+----------+<br/>\n"
"| OH | 7 |<br/>\n"
"| PA | 1 |<br/>\n"
"| SC | 1 |<br/>\n"
"| TX | 2 |<br/>\n"
"| VA | 8 |<br/>\n"
"| VT | 2 |\n"
"+-------+----------+\n"
"sdfsdf<br>\n"
"< /pre>\n"
"sdfsdf<br>\n"
"</pre>\n"
"kshdkjfkjshdf<br>\n"
"<p><br></p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")