const regex = /((?:<p|\G(?!^))(?:(?!<\/p|<\s*\/?\s*br).)*)<\s*\/?\s*br\s*\/?\s*>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:<p|\\G(?!^))(?:(?!<\\\/p|<\\s*\\\/?\\s*br).)*)<\\s*\\\/?\\s*br\\s*\\\/?\\s*>', 'gs')
const str = `These 2 lines should not be<br/>
touched. Example only.<br/><br/>
<pre class="code">mysql>
<strong> SELECT state, COUNT(*) FROM president GROUP BY state;</strong><br/>
+-------+----------+<br/>
| state | COUNT(*) |<br/>
+-------+----------+<br/>
| OH | 7 |<br/>
| PA | 1 |<br/>
| SC | 1 |<br/>
| TX | 2 |<br/>
| VA | 8 |<br/>
| VT | 2 |
+-------+----------+
sdfsdf<br>
< /pre>
sdfsdf<br>
</pre>
kshdkjfkjshdf<br>
<p><br></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}