use strict;
my $str = 'These 2 lines should not be<br/>
touched. Example only.<br/><br/>
<pre class="code">mysql>
<strong> SELECT state, COUNT(*) FROM president GROUP BY state;</strong><br/>
+-------+----------+<br/>
| state | COUNT(*) |<br/>
+-------+----------+<br/>
| OH | 7 |<br/>
| PA | 1 |<br/>
| SC | 1 |<br/>
| TX | 2 |<br/>
| VA | 8 |<br/>
| VT | 2 |
+-------+----------+
sdfsdf<br>
< /pre>
sdfsdf<br>
</pre>
kshdkjfkjshdf<br>
<p><br></p>';
my $regex = qr/((?:<p|\G(?!^))(?:(?!<\/p|<\s*\/?\s*br).)*)<\s*\/?\s*br\s*\/?\s*>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}