#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http|ftp|https):\/\/([\w_-]+(?:(?:\.[\w_-]+)+))([\w.@,^%:\/~+#-]+)([?][\w@?^=%&\/~+#-]+)+"
Local $sString = "Click Here http://www.kolishcool.mobi/mobileportal/auth?c=27&u=3422746&tn=533e7ab1374efa7c5ef3645ccf2a45043d884704510a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")