$re = '/(http|ftp|https):\/\/([\w_-]+(?:(?:\.[\w_-]+)+))([\w.@,^%:\/~+#-]+)([?][\w@?^=%&\/~+#-]+)+/';
$str = 'Click Here http://www.kolishcool.mobi/mobileportal/auth?c=27&u=3422746&tn=533e7ab1374efa7c5ef3645ccf2a45043d884704510a';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);