const regex = /(http|ftp|https):\/\/([\w_-]+(?:(?:\.[\w_-]+)+))([\w.@,^%:\/~+#-]+)([?][\w@?^=%&\/~+#-]+)+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http|ftp|https):\\\/\\\/([\\w_-]+(?:(?:\\.[\\w_-]+)+))([\\w.@,^%:\\\/~+#-]+)([?][\\w@?^=%&\\\/~+#-]+)+', '')
const str = `Click Here http://www.kolishcool.mobi/mobileportal/auth?c=27&u=3422746&tn=533e7ab1374efa7c5ef3645ccf2a45043d884704510a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}