import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|ftp|https):\\/\\/([\\w_-]+(?:(?:\\.[\\w_-]+)+))([\\w.@,^%:\\/~+#-]+)([?][\\w@?^=%&\\/~+#-]+)+";
final String string = "Click Here http://www.kolishcool.mobi/mobileportal/auth?c=27&u=3422746&tn=533e7ab1374efa7c5ef3645ccf2a45043d884704510a";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}