# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?\d//gm;t' <<< "DitchMe5KeepMe
Dit5chMe5KeepMe"