const regex = /^.*?\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\d', 'gm')
const str = `DitchMe5KeepMe
Dit5chMe5KeepMe`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);