use strict;
my $str = 'DitchMe5KeepMe
Dit5chMe5KeepMe';
my $regex = qr/^.*?\d/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";