#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+([\ _.,])?\d*(?:\1\d+)*$"
Local $sString = "1" & @CRLF & _
"1234" & @CRLF & _
"3.14159" & @CRLF & _
"12_456_789" & @CRLF & _
"123.456.789.0" & @CRLF & _
"123,456.789_987"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")