const regex = /^\d+([\ _.,])?\d*(?:\1\d+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+([\\ _.,])?\\d*(?:\\1\\d+)*$', 'gm')
const str = `1
1234
3.14159
12_456_789
123.456.789.0
123,456.789_987`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}