$re = '/^\d+([\ _.,])?\d*(?:\1\d+)*$/m';
$str = '1
1234
3.14159
12_456_789
123.456.789.0
123,456.789_987';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);