using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+([\ _.,])?\d*(?:\1\d+)*$";
string input = @"1
1234
3.14159
12_456_789
123.456.789.0
123,456.789_987";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}