# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d)/ /gi;t' <<< "new stackoverflow 244code 7490script design"