using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)(?=[a-z])|(?<=[a-z])(?=\d)";
string substitution = @" ";
string input = @"new stackoverflow 244code 7490script design";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}